$re = '/\$(?!0\d)\d+(?:\.\d{2})?(?=\s|$)/';
$str = '$34.23 $23 $23.23 $2 $2313443.23 $3422342 $02394 $230.232 $232.2 $05.03 $0.99 $3.00
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);