re = /(?=(ATG\w+?TAG))/
str = 'ACCCTGCCCAAAATCCCCCCGATCGATAGAGCTAAATGGCCCATGATGCATCGACTAGCTAGCTAAAATGTCGATCGATACAGCTAATAG'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end