$re = '/\'\s*?,\s?\'|,\s?\'|\'\s?,/';
$str = '123,678.89,\'hello there1\', \'xyz1@gmail.com\', \'abc,nds\'
123,678.89,\'hello \'there2\', \'xyz2@gmail.com\', \'akiu-\'nds\'';
$subst = "|";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;