$re = '/^(?i)(?=\D*\d)\d*[A-Z][A-Z\d]*$/';
$str = 'Abc123';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);