$re = '/\'\S+?\':\s*\'?(.*?)\'?(?:,|$)/';
$str = '\'a\': \'1\', \'b\': \'2.3\', \'c\': \'name\', \'d\': 229, \'e\': \'\', \'f\': \'228\', \'g\': 12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);