import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(struct\\s*\\w+.*?(?=fn))(fn.*?(?=\\),)\\)).*?(?=fn)(fn.*?\\))(?=\\R\\))";
final String string = "struct mbuh\n"
+ "(\n\n"
+ "lineshg = 0,\n"
+ "tres = \"text\",\n\n"
+ " fn track all:#() = \n"
+ " (\n"
+ " local c -- clone\n"
+ " local lpoint = [0,0,0] -- previous point created\n"
+ " local ccoll = #() -- array for created objects\n"
+ " local prev = [0,0] -- var for alt distance changing\n"
+ " ),\n\n"
+ " fn listzfun trs:123 x:#() = \n"
+ " (\n"
+ " obj = snapshotasmesh a\n"
+ " min_vz = max_vz = in coordsys world (getvert obj 1).z\n"
+ " min_vx = max_vx = in coordsys world (getvert obj 1).x\n"
+ " min_vy = max_vy = in coordsys world (getvert obj 1).y\n"
+ " )\n"
+ ")\n\n"
+ "struct mbuh\n"
+ "(\n\n"
+ "lineshg = 0,\n"
+ "tres = \"text\",\n\n"
+ " fn track all:#() = \n"
+ " (\n"
+ " local c -- clone\n"
+ " local lpoint = [0,0,0] -- previous point created\n"
+ " local ccoll = #() -- array for created objects\n"
+ " local prev = [0,0] -- var for alt distance changing\n"
+ " ),\n\n"
+ " fn listzfun trs:123 x:#() = \n"
+ " (\n"
+ " obj = snapshotasmesh a\n"
+ " min_vz = max_vz = in coordsys world (getvert obj 1).z\n"
+ " min_vx = max_vx = in coordsys world (getvert obj 1).x\n"
+ " min_vy = max_vy = in coordsys world (getvert obj 1).y\n"
+ " )\n"
+ ")\n\n"
+ "fn brung man: =\n"
+ "(\n\n"
+ ")";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}