#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)(?:(?<=IBAN(?:[:\s]\s|\s[:\s]))NL\s?\d{2}\s?[A-Z]{4}[0 ]\s?\d{9,10})|(?:(?<=IBAN[:\s])NL\s?\d{2}\s?[A-Z]{4}[0 ]\s?\d{9,10})"
Local $sString = "Uw BTW nummer NL80" & @CRLF & _
" IBAN NL 11abna0317164300asdfasf234" & @CRLF & _
"iBAN NL21ABNA0417134300 22" & @CRLF & _
"Iban: NL 29 ABNA 401422366f sdf" & @CRLF & _
"IBAN :NL 39 ABNA 0822416395s" & @CRLF & _
"IBAN:NL 39 ABNA 0822416395s" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")