using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/\*[^*]*\*+([^\/][^*]*\*+)*\/";
string input = @"/**
* Test function \-'-/
*
* @param nothing
*/
function test() {
/* Function */
return; /* End of
the function */
}
/* This works ! */";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}