re = /\bWordcap([^|=]*=.*?)(?=\s*\bWordcap|$)/
str = 'Tue Apr 24 22:35:48 2018 53/e33
hello:55|Wordcap|abc|abc generate|6|Wordcapdata_proto_req=WINTER Wordcapdata_sample_resp=summer 2.4.5 WordcapTotal_reject=56 WordcapAddition_sum=TEA CUP ONE'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end