$re = '~(http://|https://|www).*\.([a-z]|/d){2,3}~m';
$str = 'http://website.com/ABCDEF/GHIJKL
www.aps.gov
www.abc.al
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);