$re = '/@([^@]*)@/m';
$str = 'this is @the best@ possible way @t@o do result!!!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);