$re = '/([A-Z]+) ([0-9]+) ([A-Z]+)0?([0-9]+)/';
$str = 'ABC 318 XY2388';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);