using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:.*(?=\..*\..*).)?([^.]+)";
string input = @"lifenews.ru
www.forbes.com
goo.gl
ya.ru
a.b.c.d.e.f";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}