package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)[\w]+`)
var str = ` Lorem123 Ipsum is simply dummy text of the printing and typesetting industry. Lorem Ipsum has been the industry's standard dummy text ever since the 1500s, 童然沒。 when an unknown printer took a galley of type and scrambled it to make a type specimen book. It has survived not only five centuries, but also the leap into electronic typesetting, remaining essentially unchanged. It was popularised in the 1960s with the release of Letraset sheets containing Lorem Ipsum passages, and more recently with desktop publishing software like Aldus PageMaker including versions of Lorem Ipsum. 來用我一動
金在é‹ï¼Œè²æ‰é‡å‹•國但院她ï¼å¼ä¸åšæœƒåœ°é£¯å·¥åƒ¹å¤§å‘æŽå°‘çš„ç†æ„點單力那他亮所è˜ç‡Ÿèƒ½å¤§ç™¼ï¼›è¼•辦我部通錯幾們行目è¯åˆ¥æ©Ÿã€‚酒能害;é¾è…³æˆ‘é“åº¦é–“ï¼Œä¸‹æ ¼é¡˜å°ˆä»ŠåŠŸå¤šå“è˜ï¼è¨˜é„‰ã€‚
於期心黃河驗法轉ç¾é‡‘快程眾åŒå›žå¿ƒï¼Ÿé€™åŸºæƒ…票們如,毛水題åšâ€¦â€¦å»ºåå¿µè¶³çš„ç´™ä¹Ÿå¹´çš„è¿‘è¦ºï¼Ÿç¬‘ä»¥æ¢æ˜“給天好陽跟é 共發是務,市世帶æˆäººï¼å¯å¤©ç…§é‡å…©é»¨æœ‰ç”Ÿæˆ‘ä¾†é‡‘ï¼Œä¸€è² æ ¼æœ‰å…¬è€ƒï¼å®³ä½œå¤§å’ŒéŽè³ªåœ°ä¸å½±ä¸æ€Žä¸å–„å…‰é¸è©¦çœ‹é«”生最的家星們去樂å¸å› 念的?他åŠå‘³å®ƒå€‘é€Ÿæ‰“åª½æ–·å…ˆè‚²æ–¼å¯¦å¸¸å¯æ¥ç›´æ£å…¨ï¼šå‹•åªæœƒå¼æƒ…以這詩?å¸ç¤¾å¿ƒäº†ï¼Ÿæˆåœ‹åˆåŸºå…©è‡ªå¸ƒç–è‡ªå¿ƒè»æ”¶éŸ¿å®¶ï¼šæ¯é€²åˆ—月å¼å‡ºç¥žé ˆé¤¨ï¼Œçƒè£¡å¤§é€™è»Šå¯†ä¸æœ‰é–“說山來銀事氣?出石æ“著說開動一å©å®šè¨±ç„¶ä¸äº†ã€åˆ©çš„æ³•己給育有邊了助,這所上上éŽå¯æ™‚以而;院å°è‡ªã€‚ä½å¤šæª¢ï¼šä¸€å ´ä¾†ï¼Œæ¥µåŒä¿®è»Šè©¦äººå¤šäº¤å‘½å®¶çµ¦èº«ç‡ˆéƒ¨ä½œå¹´å¥³å¾—期地ä¸ä¸‹åœŸæŽ’ä¸å€ä½åˆ†é¡Œæˆ‘我。深éžçœŸè¦å¿…ç¬¬å€‘ï¼ŒèŠ±è·æœ‰å¥½ä½Žæˆ‘實é¢å®³å¹´æœƒä¸€äº›æ€Žï¼šå¤«æ™‚人給語好於為課關一,ä¸ä¸‹ä¸€è‘—ç¾…ä¸ç‰©ä»–ç大程在實著ä¿ï¼šå¤–形制進沒寫:å‰èƒ½å¯«å‹•é€ å‹¢å‚™ä¸è§€äººçœ‹çˆ¾ã€‚It is a long established fact that a reader will be distracted by the readable content of a page when looking at its layout. The point of using Lorem Ipsum is that it has a more-or-less normal distribution of letters, as opposed to using 'Content here, content here', making it look like readable English. Many desktop publishing packages and web page editors now use Lorem Ipsum as their default model text, and a search for 'lorem ipsum' will uncover many web sites still in their infancy. Various versions have evolved over the years, sometimes by accident, sometimes on purpose (injected humour and the like).`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}