$re = '/(?<=\w)\s*(?<!\/)\**\s+/m';
$str = 'typedef struct job{
struct job* prev; /* pointer to previous job */
void (*function)(void* arg); /* function pointer */
void* arg; /* function\'s argument */
void ** arg2;
void *a;
} job;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);