$re = '/^(([0-9]+[.][0-9]{2})\s*)+$/';
$str = '123.32
234.54
456.43';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);