package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d\d?[,.]\d\d?$`)
var str = `11,21
123.12
11.11
1.1
1,1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}