const regex = /^[\p{L}0-9_.-](?:[\p{L}0-9_. -]*[\p{L}0-9_.-])?$/u;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[\\p{L}0-9_.-](?:[\\p{L}0-9_. -]*[\\p{L}0-9_.-])?$', 'u')
const str = `àèéìòóùàbfgbhfĞ ğ Ş ş İ ı ą ć ę ł ń ó ś ź ż Ż Ź Ś Ó Ń Ł Ę Ć Ą`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}