import re
regex = re.compile(r"""
@font-face\s* # Match @font-face and some spaces
( # Start group 1
\{ # Match {
(?: # A non-capturing group
[^{}]+ # Match anything except {} one or more times
| # Or
(?1) # Recurse/rerun the expression of group 1
)* # Repeat 0 or more times
\} # Match }
) # End group 1
(*SKIP)(*FAIL) # Skip it
| # Or
url\s*\( # Match url, optionally some whitespaces and then (
\s* # Match optionally some whitespaces
("|'|) # It seems that the quotes are optional according to http://www.w3.org/TR/CSS2/syndata.html#uri
(?!["']?(?:https?://|ftp://)) # Put your negative-rules here (do not match url's with http, https or ftp)
(?:[^\\]|\\.)*? # Match anything except a backslash or backslash and a character zero or more times ungreedy
\2 # Match what was matched in group 2
\s* # Match optionally some whitespaces
\) # Match )
""", flags=re.VERBOSE | re.DOTALL)
test_str = (".someclass0 {\n"
" background: url('http://images/someimage.png') no-repeat;\n"
"}\n\n"
"@font-face {\n"
" font-family: 'FontAwesome';\n"
" src: url(\"fonts/fontawesome-webfont.eot?v=4.0.3\");\n"
" src: url(\"fonts/fontawesome-webfont.eot?#iefix&v=4.0.3\") format(\"embedded-opentype\"), url(\"fonts/fontawesome-webfont.woff?v=4.0.3\") format(\"woff\"), url(\"fonts/fontawesome-webfont.ttf?v=4.0.3\") format(\"truetype\"), url(\"fonts/fontawesome-webfont.svg?v=4.0.3#fontawesomeregular\") format(\"svg\");\n"
" font-weight: normal;\n"
" font-style: normal;\n"
"}\n\n"
".someclass1 {\n"
" background: url('images/someimage.png') no-repeat;\n"
"}\n\n"
".someclass2 {\n"
" background: url(\"images/someimage.png\") no-repeat;\n"
"}\n\n"
".someclass3 {\n"
" background: url(images/someimage.png) no-repeat;\n"
"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")