package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^((.*?)( tom.*)?)$`)
var str = `call tomorrow`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}