re = /<img\s+src\s*=\s*"(.*?)"/m
str = '"<div> <img src="https://i.testimg.com/images/g/test/s-l400.jpg" style="width: 100%;"> <div>Test</div> </div>"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end