package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\.\.+|\--+)`)
var str = `+(123-456---------7................890.......`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}