$re = '/(?:(a)|(b)|(c))(?(3)x|y)/m';
$str = 'ax
bx
cx
ay
by
cy
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);