re = /(?<=the date is ).*?(?=\s*the place is)|(?<=the place is ).*?(?=\s*the people are)|(?<=the people are ).*/
str = '<a href=\\"http://vnexpress.net/tin-tuc/the-gioi/putin-noi-se-tiep-tuc-hop-tac-voi-phuong-tay-3236453.html\\"><img width=130 height=100 src=\\"http://s.f29.img.vnecdn.net/2015/06/19/pu2-2249-1434719288_180x108.jpg\\" ></a></br>Tổng thống Nga Vladimir Putin tự tin rằng hợp tác của Moscow với Phương Tây sẽ vẫn tiếp tục, bất chấp việc Liên minh châu Âu (EU) công bố sẽ kéo dài các lệnh trừng phạt thêm 6 tháng.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end