$re = '/^(
( # define some frequently used capture groups
(?!x)x # always false ("match only if there is no \'x\' ahead and there is \'x\' ahead")
(?<name>[^_]+) # group "name", name of the program/library
(?<os>windows|linux|osx|android) # group "os", operating systems
(?<arch>x86-64|x86|arm64|armhf|armel|multiarch) # group"arch", architectures
(?<buildtype>release|debug) # group"buildtype", build types
(?<linking>shared|static|mixed) # group "linking", library linking/build types
)
|
( # regular executable builds
(?!lib)\g<name>_build_\g<os>_\g<arch>_\g<buildtype>
)
|
( # library builds
lib\g<name>_build_\g<os>_\g<arch>_\g<linking>_\g<buildtype>
)
|
( # syncing source code of a project from git or something else
\g<name>_src
)
|
( # static code analizer
\g<name>_analyze_(cppcheck|scan-build)
)
|
( # package builds
\g<name>_pkg_\g<os>_
(
((?<=linux_) # if there is "linux_" before here
# then match
(deb|rpm)_
(shared|static)_
(
((?<=deb_shared_) # if there is "deb_shared_" before here
# then match
(jessie|stretch|buster|sid|xenial|yakkety|zesty)_
)
|
((?<!deb_shared_) # if there is no "deb_shared_", don\'t match anything
)
)
)
|
((?<!linux_) # if there is no "linux_", don\'t match anything
)
)
\g<arch>_(stable|nightly)_\g<buildtype>
)
)$/x';
$str = 'qtox_pkg_linux_deb_shared_jessie_x86_stable_release';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);