package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(.*) \((1:1)\)`)
var str = `test test (1:1)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}