const regex = /^(?!i18n-.*\.js).*(?:css|js)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!i18n-.*\\.js).*(?:css|js)$', 'gm')
const str = `i18n-.js
test.js
i18n.js
i18n2.js
m43.js`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}