using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\([^)]+\)|;+$";
string substitution = @"";
string input = @"pi1(tag1,tag2);pi2(tag3,tag4,tag5);";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}