re = /(?:\([^()]*(?:\([^()]*\)[^()]*)*\)|[^,])+/m
str = 'a,(b, b),c (aaa, (bbb, cccc, ddd)),d'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end