// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([A-Z ,\.\-\&#\\\\n\/0-9&]+)(\d{10})([A-Z a-z]+)(\d{1}-\d{7}-\d{3}-\d{4}|\d{1}-\d{7}-\d{2}-\d{4})").unwrap();
let string = "\\nTHIS IS FIRST PATTERN 63101 0789158126 0-0000000-000-0000\\n4415 THIS IS FIRST \\nPATTERN 49401-9528\\n0406842931 Third match 0-0000000-000-0000\\n11403 THIS IS FIRST PATTERN 49401-\\n9595\\n0112853789 Third match 0-0000000-000-0000";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}