$re = '/<(?!br\/?>)[^<>]*>/m';
$str = '<a href="http://host.domain.tld/br">
<break> <br/> <foo> <br> <p>, <img>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);