$re = '/&atype=(\d+)/m';
$str = 'bla\'action=collect&atype=1\',bla\'action=collect&atype=3\',bla\'action=collect&atype=2\',bla\'action=collect&atype=1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);