$re = '/\[(.*?)\]/';
$str = 'This is my [word1] And this is my [word2]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);