re = /^[A-Za-z0-9!#$%&'*+\/=?^_\`{|}~-]+@([A-Za-z0-9]([A-Za-z0-9-]*[A-Za-z0-9])?\.)+[A-Za-z0-9]([A-Za-z0-9-]*[A-Za-z0-9])$/m
str = 'email@example.com
email.dot@example.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end