package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([\\n0-9\$\-,]*)`)
var str = `\\n1ST TEST TEST`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}