re = /^(https|http)?:\/\/(?:\w[\-\w.]+)(?:\/[\-\w+&@#\/%=~_|!:,.;]*)?(?:\?[\-A-Z0-9+&@#\/%=~_|!:,.;]*)?$/
str = 'https://www,google.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end