package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d+\.\d+`)
var str = `2018.1
2018.1.2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}