$re = '~^(?:.*/)?[a-zA-Z]\w*_\d{3}\.(?:vhd|vhdl|sv|v)$~m';
$str = './Qsys_Systems/MY_SYS_TB/simulation/submodules/MY_SYS_TB_mm_interconnect_0_router_001.sv
./Qsys_Systems/MY_SYS_TB/simulation/submodules/MY_SYS_TB_mm_interconnect_0_router_002.sv
./Qsys_Systems/MY_SYS_TB/simulation/submodules/MY_SYS_TB_mm_interconnect_0_router_004.sv
./Qsys_Systems/MY_SYS_TB/simulation/submodules/1_MY_SYS_TB_mm_interconnect_0_router.sv
./Qsys_Systems/MY_SYS_TB/simulation/submodules/_MY_SYS_TB_mm_interconnect_0_router.sv
./Qsys_Systems/MY_SYS_TB/simulation/submodules/MY_SYS_TB_mm_interconnect_0_router.sv
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);