re = /(?i)(?<!John\s)Smith |(?i)(Smith.*\s(?!John))/m
str = 'Smith but not if John Smith or Smith John'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end