$re = '/(?i)(?<!John\s)Smith.*\s(?!John)/m';
$str = 'Smith but not if John Smith or Smith John';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);