# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\/wp-content\/themes\/"
test_str = ("0 = /path/to/file/index.php\n"
"1 = /path/to/file/wp-blog-header.php\n"
"2 = /path/to/file/wp-load.php\n"
"3 = /path/to/file/wp-config.php\n"
"4 = /path/to/file/wp-settings.php\n"
"5 = /path/to/file/wp-includes/load.php\n"
"6 = /path/to/file/wp-includes/default-constants.php\n"
"7 = /path/to/file/wp-includes/version.php\n"
"8 = /path/to/file/wp-includes/compat.php\n"
"9 = /path/to/file/wp-includes/functions.php\n"
"10 = /path/to/file/wp-includes/option.php\n"
"[...]\n"
"219 = /path/to/file/wp-content/plugins/advanced-custom-fields/core/fields/page_link.php\n"
"220 = /path/to/file/wp-content/plugins/advanced-custom-fields/core/fields/post_object.php\n"
"221 = /path/to/file/wp-content/plugins/advanced-custom-fields/core/fields/relationship.php\n"
"222 = /path/to/file/wp-content/plugins/advanced-custom-fields/core/fields/taxonomy.php\n"
"223 = /path/to/file/wp-content/plugins/advanced-custom-fields/core/fields/user.php\n"
"224 = /path/to/file/wp-content/plugins/advanced-custom-fields/core/fields/date_picker/date_picker.php\n"
"225 = /path/to/file/wp-content/plugins/advanced-custom-fields/core/fields/color_picker.php\n"
"226 = /path/to/file/wp-content/plugins/advanced-custom-fields/core/fields/message.php\n"
"227 = /path/to/file/wp-content/plugins/advanced-custom-fields/core/fields/tab.php\n"
"228 = /path/to/file/wp-content/plugins/add-to-any/add-to-any-wp-widget.php\n"
"229 = /path/to/file/wp-includes/class-wp-admin-bar.php\n"
"230 = /path/to/file/wp-includes/template-loader.php\n"
"231 = /path/to/file/wp-content/themes/themename/category.php\n"
"232 = /path/to/file/wp-content/themes/themename/header.php\n"
"233 = /path/to/file/wp-content/themes/themename/content.php\n"
"234 = /path/to/file/wp-content/themes/themename/sidebar.php\n"
"235 = /path/to/file/wp-content/themes/themename/footer.php")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.