#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\d{1,3}) .+ (\d{1,3})$"
Local $sString = "1 France Inter 20 715 889 24 273 500 13 810 922 34m 08s 1" & @CRLF & _
"2 RMC 17 180 433 19 752 536 10 526 607 31m 59s 1" & @CRLF & _
"3 NRJ 15 516 303 24 951 582 14 132 481 33m 59s 616" & @CRLF & _
"4 France Info 8 937 976 12 289 702 5 593 152 27m 18s 1" & @CRLF & _
"5 FIP 7 133 107 9 699 359 9 845 186 1h 00m 54s 11" & @CRLF & _
"6 Nostalgie 6 970 630 9 452 571 7 978 721 50m 39s 75" & @CRLF & _
"7 Skyrock 6 311 504 7 364 101 2 958 348 24m 06s 11" & @CRLF & _
"8 Chérie FM 6 207 971 8 411 056 7 471 224 53m 18s 79" & @CRLF & _
"9 France Culture 5 715 325 7 137 407 2 758 059 23m 11s 1" & @CRLF & _
"10 Rire et Chansons 4 858 398 5 936 229 3 190 343 32m 15s 25" & @CRLF & _
"11 France Bleu 3 744 498 4 235 114 3 083 072 43m 41s 45" & @CRLF & _
"12 Oui FM 2 678 447 3 066 253 2 305 722 45m 07s 20" & @CRLF & _
"13 Radio Public Sante 2 421 619 2 424 740 180 762 04m 28s 8" & @CRLF & _
"14 Radio Classique 2 081 495 2 568 342 2 339 576 54m 39s 1" & @CRLF & _
"15 France Musique 1 631 388 2 142 822 1 514 065 42m 24s 8" & @CRLF & _
"16 Radio Meuh 1 444 456 1 735 126 1 955 028 1h 07m 36s 1" & @CRLF & _
"17 Jazz Radio 1 296 883 2 232 240 1 823 211 49m 00s 30" & @CRLF & _
"18 Radio FG 1 268 787 1 723 771 1 546 692 53m 50s 8" & @CRLF & _
"19 M Radio 1 243 368 1 435 268 982 991 41m 06s 21" & @CRLF & _
"20 Latina 1 234 321 1 548 546 823 327 31m 54s 8" & @CRLF & _
"21 Radio Nova 1 146 752 1 439 584 1 266 673 52m 48s 5" & @CRLF & _
"22 Djam Radio 1 061 059 1 332 371 824 642 37m 08s 1" & @CRLF & _
"23 Chante France 1 036 497 1 484 925 1 083 948 43m 48s 7" & @CRLF & _
"24 Hotmixradio 1 012 057 3 556 711 2 185 403 36m 52s 20" & @CRLF & _
"25 BFM Business 994 745 1 290 789 707 847 32m 54s 1" & @CRLF & _
"26 Générations 968 303 1 317 853 491 625 22m 23s 28" & @CRLF & _
"27 Mouv 886 328 1 003 387 466 052 27m 52s 7" & @CRLF & _
"28 Outre-Mer la 1ère 636 343 695 384 344 918 29m 46s 10" & @CRLF & _
"29 TSF Jazz 615 188 855 646 835 809 58m 37s 1" & @CRLF & _
"30 Radio Scoop 554 268 608 459 407 005 40m 08s 19" & @CRLF & _
"31 Sud Radio 515 576 593 386 319 693 32m 20s 1" & @CRLF & _
"32 Tropiques 468 281 496 499 272 790 32m 58s 6" & @CRLF & _
"33 Alouette 429 218 479 216 365 439 45m 45s 2" & @CRLF & _
"34 Voltage 418 581 505 578 264 571 31m 24s 9" & @CRLF & _
"35 Vibration 397 046 458 878 267 638 35m 00s 10" & @CRLF & _
"36 HItwest 357 319 390 501 360 035 55m 19s 3" & @CRLF & _
"37 Beur FM 329 434 460 259 126 455 16m 29s 1" & @CRLF & _
"38 Allzic 303 841 572 798 421 020 44m 06s 56" & @CRLF & _
"39 Contact FM 291 186 325 642 253 455 46m 42s 1" & @CRLF & _
"40 Top Music 278 818 322 765 320 289 59m 32s 1" & @CRLF & _
"41 Evasion 266 087 289 990 267 630 55m 22s 1" & @CRLF & _
"42 Swigg * 257 019 312 769 92 619 17m 46s 11" & @CRLF & _
"43 100% 255 271 324 096 240 839 44m 35s 6" & @CRLF & _
"44 Radio Bonheur 250 947 321 292 222 426 41m 32s 1" & @CRLF & _
"45 Bien Etre animal 246 007 246 030 11 163 02m 43s 1" & @CRLF & _
"46 Wit FM 244 992 277 388 159 541 34m 31s 10" & @CRLF & _
"47 Champagne FM 227 003 245 636 170 703 41m 42s 1" & @CRLF & _
"48 Replay News 205 278 206 073 6 617 01m 56s 1" & @CRLF & _
"49 Maritima 180 281 185 693 43 114 13m 56s 1" & @CRLF & _
"50 Radio Mélodie 174 841 204 867 198 426 58m 07s 2" & @CRLF & _
"51 Radio Pomme d'Api 171 118 209 135 133 074 38m 11s 1" & @CRLF & _
"52 France Maghreb 2 163 365 261 861 78 133 17m 54s 1" & @CRLF & _
"53 Metropolys 156 542 172 463 221 723 1h 17m 08s 5" & @CRLF & _
"54 Africa 144 223 409 836 126 360 18m 30s 7" & @CRLF & _
"55 Tendance ouest 144 002 167 886 163 257 58m 21s 6" & @CRLF & _
"56 Urban Hit 140 412 227 337 75 468 19m 55s 7" & @CRLF & _
"57 Radio Dreyeckland 132 434 156 076 143 591 55m 12s 5" & @CRLF & _
"58 Magnum La Radio 129 171 136 689 124 777 54m 46s 1" & @CRLF & _
"59 Kiss FM 112 876 168 535 133 025 47m 21s 4" & @CRLF & _
"60 Delta FM 105 060 117 017 110 846 56m 50s 1" & @CRLF & _
"61 Radio isa 102 101 109 297 68 957 37m 51s 1" & @CRLF & _
"62 Totem 93 911 101 285 81 368 48m 12s 1" & @CRLF & _
"63 Forum 84 515 104 104 67 951 39m 10s 9" & @CRLF & _
"64 Horizon Radio 82 240 87 601 72 733 49m 49s 1" & @CRLF & _
"65 Blackbox * 78 731 117 284 34 220 17m 30s 12" & @CRLF & _
"66 Radio Espace 77 651 97 714 52 541 32m 16s 5" & @CRLF & _
"67 Virage Radio 77 621 99 800 63 411 38m 07s 5" & @CRLF & _
"68 Radio Cristal 76 890 81 977 57 613 42m 10s 1" & @CRLF & _
"69 Toulouse Fm 72 924 83 889 67 724 48m 26s 3" & @CRLF & _
"70 Radio Médecine Douce 72 064 83 934 29 301 20m 57s 1" & @CRLF & _
"71 Radio 6 71 276 81 532 79 535 58m 32s 1" & @CRLF & _
"72 Radio Star 71 198 80 609 44 895 33m 25s 5" & @CRLF & _
"73 RTS 70 411 78 340 69 142 52m 57s 3" & @CRLF & _
"74 Jordanne FM 63 734 75 496 68 095 54m 07s 1" & @CRLF & _
"75 Melody Vintage Radio 63 235 77 952 52 218 40m 12s 1" & @CRLF & _
"76 RDL 63 075 70 884 66 696 56m 27s 1" & @CRLF & _
"77 La Radio Plus 57 033 112 816 58 375 31m 03s 4" & @CRLF & _
"78 Radio Emotion 53 093 72 516 65 094 53m 52s 3" & @CRLF & _
"79 ODS la radio 52 041 61 145 49 353 48m 26s 2" & @CRLF & _
"80 Mona fm 51 082 59 956 64 469 1h 04m 31s 1" & @CRLF & _
"81 ABC Lounge 49 182 220 272 358 520 1h 37m 39s 1" & @CRLF & _
"82 Generation Soul Disco Funk 48 009 182 509 139 471 45m 51s 1" & @CRLF & _
"83 Direct fm 47 762 54 986 39 305 42m 53s 1" & @CRLF & _
"84 ABC Dance Radios 46 157 242 544 56 739 14m 02s 6" & @CRLF & _
"85 MBS 45 708 48 683 47 429 58m 27s 1" & @CRLF & _
"86 Cannes Radio 45 006 69 588 52 358 45m 09s 2" & @CRLF & _
"87 Est FM 41 972 45 627 48 279 1h 03m 29s 1" & @CRLF & _
"88 Océane FM 41 073 48 925 40 965 50m 14s 1" & @CRLF & _
"89 Alpes 1 36 716 49 146 35 461 43m 18s 1" & @CRLF & _
"90 Fréquence Plus 36 487 41 077 28 581 41m 45s 1" & @CRLF & _
"91 Radio mont blanc 35 648 46 891 38 660 49m 28s 1" & @CRLF & _
"92 Lor FM 35 293 41 678 37 771 54m 23s 1" & @CRLF & _
"93 Mixx fm 34 140 36 251 20 139 33m 20s 1" & @CRLF & _
"94 N radio 33 858 36 460 33 735 55m 31s 1" & @CRLF & _
"95 Radio Mozart 28 988 97 921 57 309 35m 07s 1" & @CRLF & _
"96 Radio numero 1 28 465 31 972 20 918 39m 15s 1" & @CRLF & _
"97 Gold fm 27 001 32 114 15 656 29m 15s 1" & @CRLF & _
"98 Cerise FM 23 954 30 114 22 868 45m 34s 2" & @CRLF & _
"99 K6FM 23 072 25 195 19 178 45m 40s 1" & @CRLF & _
"100 Activ Radio 22 783 29 331 24 330 49m 46s 1" & @CRLF & _
"101 Lovely 20 286 24 341 16 402 40m 26s 1" & @CRLF & _
"102 Radio 8 18 994 21 994 16 595 45m 16s 1" & @CRLF & _
"103 Oxygene Radio 18 013 21 108 18 825 53m 31s 1" & @CRLF & _
"104 Radio One 17 442 20 878 16 926 48m 39s 1" & @CRLF & _
"105 Lyon 1ère 16 667 23 589 10 399 26m 27s 1" & @CRLF & _
"106 47fm 15 998 20 356 16 127 47m 32s 1" & @CRLF & _
"107 Latitude 15 241 17 578 11 587 39m 33s 1" & @CRLF & _
"108 Happy fm 14 189 19 196 9 852 30m 48s 1" & @CRLF & _
"109 ECN 12 298 18 596 15 970 51m 32s 1" & @CRLF & _
"110 Radio Menergy 11 725 13 228 10 647 48m 18s 1" & @CRLF & _
"111 RJM Radios 11 699 45 931 31 503 41m 09s 7" & @CRLF & _
"112 Jaime Radio 8 226 9 266 7 691 49m 48s 1" & @CRLF & _
"113 Radio VFM 7 179 9 756 7 711 47m 26s 1" & @CRLF & _
"114 Fréquence Grand Lacs 6 850 10 781 8 797 48m 58s 1" & @CRLF & _
"115 Grand Sud FM 6 625 8 990 6 652 44m 24s 1" & @CRLF & _
"116 Durance FM 6 173 7 650 5 680 44m 33s 1" & @CRLF & _
"117 Babymixradio 5 905 12 621 10 055 47m 48s 1" & @CRLF & _
"118 Ambient and Lounge 4 809 11 725 12 271 1h 02m 48s 1" & @CRLF & _
"119 Viv radio 3 608 4 280 3 160 44m 18s 1" & @CRLF & _
"120 1000 Hits Sweet Radio 2 668 22 927 27 312 1h 11m 29s 1" & @CRLF & _
"121 Radio Junior 194 295 101 20m 36s 1" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")