re = /".*?(?<!\\)"(*SKIP)(*F)|\bsection\b/
str = '"section", section, "section \\"section\\" section" section'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end