$re = '/^(?=.*[0-9])[- +()0-9]+$/m';
$str = '92134
+234234
-234234
234(234)
()+-';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);