import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a([^>]*+)>\\s*+<img([^>]*+)>\\s*+<\\/a>";
final String string = "<h4>Bild mit Verlinkung und ohne Caption</h4>\n\n"
+ "<p><a title=\"\" data-original-title=\"\" href=\"/site/assets/files/1807/bora_bora_3.jpg\"><img alt=\"Rochen\" class=\"align_left\" src=\"/site/assets/files/1807/bora_bora_3.150x0-is.jpg\" width=\"150\"></a>Lorem ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumy eirmod tempor invidunt ut labore et dolore magna aliquyam erat, sed diam voluptua. At vero eos et accusam et justo duo dolores et ea rebum. Stet clita kasd gubergren, no sea takimata sanctus est Lorem ipsum dolor sit amet. Lorem ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumy eirmod tempor invidunt ut labore et dolore magna aliquyam erat, sed diam voluptua. At vero eos et accusam et justo duo dolores et ea rebum. Stet clita kasd gubergren, no sea takimata sanctus est Lorem ipsum dolor sit amet.</p>\n\n"
+ "<h4>Bild mit Verlinkung und mit Caption</h4>\n\n"
+ "<figure class=\"align_left\"><a title=\"\" data-original-title=\"\" href=\"/site/assets/files/1807/bora_bora_3.jpg\">\n"
+ "<img alt=\"Rochen\" src=\"/site/assets/files/1807/bora_bora_3.132x0-is.jpg\" width=\"132\"></a>\n\n"
+ "<figcaption>Rochen</figcaption></figure><p>Lorem ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumy eirmod tempor invidunt ut labore et dolore magna aliquyam erat, sed diam voluptua. At vero eos et accusam et justo duo dolores et ea rebum. Stet clita kasd gubergren, no sea takimata sanctus est Lorem ipsum dolor sit amet. Lorem ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumy eirmod tempor invidunt ut labore et dolore magna aliquyam erat, sed diam voluptua. At vero eos et accusam et justo duo dolores et ea rebum. Stet clita kasd gubergren, no sea takimata sanctus est Lorem ipsum dolor sit amet.</p>";
final String subst = "<a$1 class=\"thumbnail\"><div class=\"scalecontainer\"><span class=\"roll\"></span><img$2></div></a>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}