# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<a(.*?)><img(.*?)(\\/)?><\\/a>/<a$1 class="thumbnail"><div class="scalecontainer"><span class="roll"><\/span><img$1><\/div><\/a>/Uig;t' <<< "<h4>Bild mit Verlinkung und ohne Caption</h4>
<p><a title=\"\" data-original-title=\"\" href=\"/site/assets/files/1807/bora_bora_3.jpg\"><img alt=\"Rochen\" class=\"align_left\" src=\"/site/assets/files/1807/bora_bora_3.150x0-is.jpg\" width=\"150\"></a>Lorem ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumy eirmod tempor invidunt ut labore et dolore magna aliquyam erat, sed diam voluptua. At vero eos et accusam et justo duo dolores et ea rebum. Stet clita kasd gubergren, no sea takimata sanctus est Lorem ipsum dolor sit amet. Lorem ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumy eirmod tempor invidunt ut labore et dolore magna aliquyam erat, sed diam voluptua. At vero eos et accusam et justo duo dolores et ea rebum. Stet clita kasd gubergren, no sea takimata sanctus est Lorem ipsum dolor sit amet.</p>
<h4>Bild mit Verlinkung und mit Caption</h4>
<figure class=\"align_left\"><a title=\"\" data-original-title=\"\" href=\"/site/assets/files/1807/bora_bora_3.jpg\"><img alt=\"Rochen\" src=\"/site/assets/files/1807/bora_bora_3.132x0-is.jpg\" width=\"132\"></a>
<figcaption>Rochen</figcaption></figure><p>Lorem ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumy eirmod tempor invidunt ut labore et dolore magna aliquyam erat, sed diam voluptua. At vero eos et accusam et justo duo dolores et ea rebum. Stet clita kasd gubergren, no sea takimata sanctus est Lorem ipsum dolor sit amet. Lorem ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumy eirmod tempor invidunt ut labore et dolore magna aliquyam erat, sed diam voluptua. At vero eos et accusam et justo duo dolores et ea rebum. Stet clita kasd gubergren, no sea takimata sanctus est Lorem ipsum dolor sit amet.</p>"