$re = '/@(\w+)\b/';
$str = 'Tweet @one two @three four @last
@first @second';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);