package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((D|O|0|3|\}|>|\*\<\||\|)?(%|#|\||x|X|B|8|:|;|\=)('|")?(\^|c|-|‑|o|っ)?(D|\)|\(|c|<|\[|\]|C|{|}|\||\&|>|\||3|Þ|þ|b|p|P|o|O|J|L|S|s|X|\\|\.|/|\$|\*|#|@))`)
var str = `:( Hello!
Howdy :)!
Are you there :P?
I'm fine :)
:p
:O
:3
:|
:/
:\
:$
:*
:@
:(
:-(
:-)
:-P
:-p
:-O
:-3
:-|
:-/
:-\
:-$
:-*
:-@
:^(
:^)
:^P
:^p
:^O
:^3
:^|
:^/
:^\
:^$
:^*
:^@
):
(:
$:
*:
)-:
(-:
$-:
*-:
)^:
(^:
$^:
*^:
<3
</3
<\3
:‑)
:)
:D
:o)
:-)
:]
:3
:c)
:>
:-&
=]
8)
=)
:}
:^)
:‑D
8‑D
8D
x‑D
xD
X‑D
XD
=‑D
=D
=‑3
=3
B^D
:-))
>:[
:‑(
:(
:‑c
:c
:-<
:っC
:<
:-<
:‑[
:[
:{
;(
:-||
:@
>:(
:'‑(
:"(
:"-(
:'(
:'‑)
:')
D:<
D:
D8
D;
D=
DX
v.v
D‑':
:'-D
>:O
:‑O
:O
:‑o
:o
8‑0
O_O
o‑o
O_o
o_O
o_o
owo
Owo
OwO
ouo
OuO
O-O
:*
:^*
;‑)
;)
;‑]
;]
;D
;^)
>:P
:‑P
:P
X‑P
x‑p
xp
XP
:‑p
:p
=p
:‑Þ
:Þ
:þ
:‑þ
:‑b
:b
d:
>:\
>:/
:‑/
:‑.
:/
:\
:L
=/
=\
:L
=L
:S
>.<
>/<
>//<
>///<
:|
:‑|
:$
:‑X
:X
:‑#
:#
O:‑)
0:‑3
0:3
0:‑)
0:)
0;^)
>:)
>;)
>:‑)
}:‑)
}:)
3:‑)
3:)
>_>
^ ^
^_^
^_<
>_^
<_<
|;-)
|-O
:-J
:-&
:&
#-)
#)
%-)
%)
:|
:o|
:-|
ಠ_ಠ
:-\
*<|:-)
<3 </3
ˊ_>ˋ
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}