import re
regex = re.compile(r"(?:[.!)?])\"?\s{1,2}([a-zA-Z]+)(?=\s)", flags=re.MULTILINE)
test_str = ("\"This is that.\" When did it happen? (ending in quotes/or FN call)\n"
" This is that. When did it happen? (note quotes are gone)\n"
" This is that. When did it happen? (notice the double space)\n"
" This is that. when did it happen? (notice the lowercase w)\n"
" This is that? When did it happen? (notice the question mark)\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")