import re
regex = re.compile(r"^(\d+)\.\s*A B C(?:\s*\n\1\b.*)*", flags=re.MULTILINE)
test_str = ("text = '7\n"
"\\x0c\n"
"7. A B C\n\n"
"7.1 bla bla bla .\n\n"
"7.2 another bla bla \n\n"
"7.3 and another one.\n\n"
"8. X Y Z\n\n"
"8.1 ha ha ha \n\n"
"(a) hohoho ;\n\n"
"(b) hihihi,\n\n"
"8'\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")